Enterprise Archive (EAR) file not being updated in TIBCO BusinessEvents Studio.

Enterprise Archive (EAR) file not being updated in TIBCO BusinessEvents Studio.

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Article ID: KB0091576

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
=========
Enterprise Archive (EAR) file not being updated in TIBCO BusinessEvents Studio.

Environment:
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TIBCO BusinessEvents 5.1.1
Windows

Symptoms:
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The Enterprise Archive file in BusinessEvents Studio does not appear to be updating correctly.

Cause:
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Once the EAR file has been created using (Build Enterprise Archive File in Studio), the timestamp should update where the file has been saved. The EAR file does not need to be deleted before recreation. It will update over the existing EAR file.

In this example, the customer environment was Windows. There could be a possibility where the location for the file being written is open in Windows Explorer. If this is the case, it may appear to the customer that the file has not been created successfully and overwritten.


Resolution:
============
Try each of the points below to try and resolve the issue.

1). If this is a new installation, ask the customer to run the command using the command prompt. Change the directory to {BE_HOME}/studio/eclipse and run the command:

  studio -clean -initialize

2). Create a new workspace in Studio and re-import the project and try building the EAR file again.

3). Check the timestamp of the location of the EAR file and confirm that Windows Explorer has updated this. It can sometimes be that if the Explorer window is open, the timestamp doesn’t always get updated.

If the issue is not resolved by the above it could be an installation issue and other lines of investigation would be required.

Issue/Introduction

Enterprise Archive (EAR) file not being updated in TIBCO BusinessEvents Studio.