Products | Versions |
---|---|
TIBCO Hawk Database Adapter | - |
Not Applicable | - |
Resolution:
Description:
This error will be seen in the hawk.log if you apply the schedule to the rulebase which invoke the DynamicQuery of TIBCO Hawk Database Adapter™ when the rulebase is out of schedule and the database is restarted during this time.
Environment:
All
Symptoms:
The rulebase did not work. You will find “closed connection” error in the hawk.log.
Cause:
Product defects of the reconnection part.
Resolution:
There are several workarounds for this issue:
1. Restart TIBCO Hawk Database Adapter™ instance.
2. Don’t apply the schedule to this kind of rulebase.
3. Create a DB ping rule to ping the same database and don’t apply any schedule to this rule. This rule will keep the connection alive even the actually rule is out of schedule.