Products | Versions |
---|---|
TIBCO Administrator | - |
Not Applicable | - |
Resolution:
Description:
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"IllegalArgumentException: Could not find an application archive associated with a deployment configuration for ApplicationConfiguration: TIBCO Servers” appears in the Administrator.log when clicking EMS or TIBCO Administrator service instance on the TIBCO Administrator GUI.
Environment:
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TIBCO Administrator 5.6.x
TIBCO Runtime Agent 5.6.x
Symptoms:
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The following IllegalArgumentException appears in Administrator.log
<-------
2009 Sep 07 10:37:28:310 GMT +8 Error [Administrator] AESDKJ-0000 [http-8090-Processor44] java.lang.IllegalArgumentException: Could not find an application archive associated with a deployment configuration for ApplicationConfiguration: TIBCO Servers
at com.tibco.pof.admindomain.impl.DeploymentConfigurationImpl.getUploadedApplicationArchive(DeploymentConfigurationImpl.java:805)
at com.tibco.pof.admindomain.impl.ServiceConfigurationImpl.getUploadedServiceArchive(ServiceConfigurationImpl.java:349)
at com.tibco.be.deployment.administrator.BEServiceInstanceGeneralTab.isAvailable(BEServiceInstanceGeneralTab.java:33)
------>
Cause:
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This is an eror complaining that the archive file could not be found for “TIBCO Servers”. Unlike BW/Adapter applications, a Tibco server application does NOT have an archive file (.ear file) stored in the domain. This is why the debug info appears.
Resolution:
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It is harmless and can be safely ignored. There is a Change Request (ADM-3650) submitted for this issue.