Products | Versions |
---|---|
TIBCO Nimbus | - |
Not Applicable | - |
Description:
When running the TIBCO Nimbus Performance counters on 64 bit versions of the Windows operating
system the counters do not record any results in log files even when running the 32 bit version of Windows
Performance Monitor (PerfMon) via “mmc.exe /32 perfmon.msc”.
The counters do show in Performance Monitor, just not in log files. If a log file that is created when it is
opened it will be blank and the following error message is usually displayed:
“The data source is not in active mode, this is generally caused by invalid log files.”
Symptoms:
When running the TIBCO Nimbus Performance counters on 64 bit versions of the Windows operating
system the counters do not record any results in log files even when running the 32 bit version of Windows
Performance Monitor (PerfMon) via “mmc.exe /32 perfmon.msc”.
The counters do show in Performance Monitor, just not in log files. If a log file that is created when it is
opened it will be blank and the following error message is usually displayed:
“The data source is not in active mode, this is generally caused by invalid log files.”
Cause:
As the current TIBCO Nimbus performance counters are provided by a 32 bit DLL file they can only be
loaded by a 32 bit process. This is the reason that the 32 bit version of Performance Monitor needs to be
run. However when using Data Collector sets there is another process completing the logging and by
default it’s a 64 bit process and so cannot load the TIBCO Nimbus performance counter DLL file. This leads
it to log empty entries.
To resolve this situation Windows 2008 R2 and later provides additional support to host 32 bit counter dlls.
However due to a bug in the registration code in the TIBCO Nimbus performance counter library
(cesctrs.dll) an incorrect registry key is created that prevents this support from working.