Products | Versions |
---|---|
TIBCO BusinessConnect | - |
Not Applicable | - |
Description:
A BusinessWorks process generating Document IDs for BusinessConnect outbound documents may generate a duplicate ID for different transactions.
Symptoms:
As described.
Cause:
There is an issue with how the BC Palette generates the Document ID inside BusinessWorks.
As a workaround, disable the "Generate Uniqute Transaction ID" in the BC Palette and generate the Document ID manually by using the following formula:
“prefix+EngineName+ProcessID+timestamp”
The prefix is customer defined to differentiate deployments. The EngineName,ProcessID, and timestamp are BW5 engine process variables.