The Gateway Server Instance is not showing up in Administrator even when it is running.

The Gateway Server Instance is not showing up in Administrator even when it is running.

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Article ID: KB0093384

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
After BusinessConnect's (BC) Gateway Service (GS) engine starts up successfully without any RV exceptions or issues, the instance does not show up in Administrator under Admininstrator/BusinessConnect/Gateway/Gateway Instances.
Symptoms:
As described above. Also, in the Interior server logs, the following exception is reported. 


"Error connecting via JMX to Gateway.: Failed to retrieve RMIServer stub: javax.naming.ConfigurationException [Root exception is java.rmi.UnknownHostException: Unknown host".


Cause:
The machines on which the interior server and admin are running are not able to recognize the machine on which the GS engine is running. This is the reason why the the "Unknown host" exception is thrown.

Resolution

The machine should be recognizable via either a DNS lookup or in the etc/hosts file of the interior machine. If DNS is not available or the GS server hostname is not registered correctly, the GS machine should be mapped correctly in the /etc/hosts file so that interior server is able to recognize the GS engine machine. 

Below is an example illustrating this mapping. This mapping is done in the /etc/hosts file on the interior machine such that it recognizes the ipaddress, name and the fully qualified name of the GS engine. a70apcomtbco006 is the machine on which GS engine is running.
 
10.242.4.123     a70apcomtbco006.a70addmz.ad   a70apcomtbco006

Issue/Introduction

The Gateway Server Instance is not showing up in Administrator even when it is running.