TIBCO InConcert (IC) server reports, "Row Not Found" when updating a string attribute.

TIBCO InConcert (IC) server reports, "Row Not Found" when updating a string attribute.

book

Article ID: KB0093437

calendar_today

Updated On:

Products Versions
TIBCO InConcert -
Not Applicable -

Description

Description:
The debug log will log the entry, "13:30:16 (wrkr) 13069: debug: RPC done: 000007 Severity: 3 Time: 0.014 Queued: 0 Row Not Found." . Note, there can be more than one cause for this error.

Symptoms:
This problem may be intermittent. Other symptoms include the following output from the IcJavaExample JNI example1 code:

/usr/lib/jvm/java-1.6.0-openjdk/bin/java IcJavaExample  Cannot find MIME types file, using default null
Cannot find MIME types file, using default null
IcClient.directInitialize() succeeded...
client.getBaseTemplate() succeeded...
baseTemplate.createTemplate() succeeded...
newTemplate.getRootTask() succeeded...
rootTask.addTask() succeeded...
rootTask.addTask() succeeded...
client.getAdminPool() succeeded...
newTemplate.createActive() succeeded...
activeJob.getRootTask() succeeded...
rootTask.getChildren() succeeded...
client.terminate() succeeded...

The output you should see is:

java IcJavaExample
Cannot find MIME types file, using default null
Cannot find MIME types file, using default null
IcClient.directInitialize() succeeded...
client.getBaseTemplate() succeeded...
baseTemplate.createTemplate() succeeded...
newTemplate.getRootTask() succeeded...
rootTask.addTask() succeeded...
client.getAdminPool() succeeded...
newTemplate.createActive() succeeded...
activeJob.getRootTask() succeeded...
rootTask.getChildren() succeeded...
myTaskName: task.setAttributeString() succeeded...
myTaskName: task.getAttributeString() succeeded...
myTaskName: task.getStatus() succeeded...
myTaskName: task.acquire() succeeded...
myTaskName: task.exportId() succeeded...
myTaskName: client.validateForImport() succeeded...
myTaskName: client.importId() succeeded...
myTaskName: task.complete() succeeded...
client.terminate() succeeded...


Cause:
The cause of the problem is having a different version of an Oracle client compared with the Oracle server. The Oracle server was version Oracle 11.2.0.1 and the Oracle client 11.2.0.4.

Resolution

Install and use Oracle 11.2.0.3 for the client version.

Issue/Introduction

TIBCO InConcert (IC) server reports, "Row Not Found" when updating a string attribute.