DateTime field values differ when starting BusinessEvents Agents in different timezones.

DateTime field values differ when starting BusinessEvents Agents in different timezones.

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Article ID: KB0093873

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
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DateTime field values differ when starting BusinessEvents Agents in different timezones.

Environment:
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BusinessEvents 3.0/4.0
All Operating Systems

Symptoms:
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Create a concept with a timestamp. Change the timezone for the machine or start BusinessEvents agents on a machine with a different timezone.  Load the concept. The timestamp for the concept will be different.

Cause:
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product defect (BE-12377, BE-12160)

Resolution:
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Issue is fixed beginning with version 4.0.1HF2 and 3.0.2.HF5 . You must add the property 'be.backingstore.timestamp.useDataTimeZone=true'  to enable the fix (was required to guarantee that timestamp values had not been changed for BusinessEvents agents started on the same timezone).

Issue/Introduction

DateTime field values differ when starting BusinessEvents Agents in different timezones.