TIBCO BusinessConnect engine fails to start with an EMS SSL exception.

TIBCO BusinessConnect engine fails to start with an EMS SSL exception.

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Article ID: KB0093906

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
If bc.securityVendor.sockets is set to Sun and BC connects to an EMS SSL server, the BC engine fails to start.
Symptoms:

BC engine fails to start with the following error:


RuntimeBootsrtap:sInit Error connecting to JMS Server.Not permitted: Failed to connect to any server at: ssl://ip:port [Error: Failed to initialize SSL client: java.lang.RuntimeException: com.tibco.security.AXSecurityException: no certificate suitable for signing is available: url that returned this exception = SSL://ip:port ] . Attempting to reconnect.
Cause:
This issue is caused by the underlying “TPCL_HOME/lib/entrust/enttoolkit.jar" file that is included in TRA 5.8.0. This version of the JAR file cannot connect to EMS6.0 - EMS6.2.

Resolution

Make sure to use the supported EMS version by BC 6.2.1. It supports TIBCO Enterprise Message Service 6.3.0 - 8.2.x.

Issue/Introduction

TIBCO BusinessConnect engine fails to start with an EMS SSL exception.

Additional Information

Refer to the readme file of BC 6.2.1 for more details about TIBCO Product compatibility.