TIBCO BusinessEvents Monitoring Management (BEMM) console does not display statistics.

TIBCO BusinessEvents Monitoring Management (BEMM) console does not display statistics.

book

Article ID: KB0094312

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
============
TIBCO BusinessEvents Monitoring Management does not display the statistics of the running engines when Hawk is used to start remote BE engines.

Environment:
==========
Operating system: Linux
TIBCO BusinessEvents (BE) version: 4.x

Symptoms:
=========
Even though the BusinessEvents engines are started successfully from the BEMM console, there won't be any stats displayed.

Cause:
=====
Firewall blocking the ports used by BEMM.

Resolution:
=========
Disabled Firewall on the Linux box.

OR

Make sure that you have your be-engine.tra file modified to accept the jmx_port variable:

java.property.com.sun.management.jmxremote.ssl=false
java.property.com.sun.management.jmxremote.port=%jmx_port%
java.property.com.sun.management.jmxremote.authenticate=false

Note: On Windows, make sure the Anti-Virus is not blocking the ports used by BEMM.

Issue/Introduction

TIBCO BusinessEvents Monitoring Management (BEMM) console does not display statistics.