Products | Versions |
---|---|
TIBCO BusinessEvents Enterprise Edition | - |
Not Applicable | - |
Resolution:
Description:
============
The be-engine fails to start and no log file or directory is created.
Environment:
==========
All
Symptoms:
=========
See above.
Cause:
=====
Bad definitions for JVM in be-engine.tra. Ensure that the following are correctly set:
tibco.env.TIB_JAVA_HOME=%NON_DEFINED%
tibco.env.JVM_LIB_PATH=%NON_DEFINED%
tibco.env.JVM_LIB_DIR=%NON_DEFINED%
If you use a parameter for the above paths make sure to define it in the be-engine.tra file. Below are settings on Windows that did work.
tibco.env.TIB_JAVA_HOME=C:/tibco_401/tibcojre/1.6.0
tibco.env.JVM_LIB_PATH=C:/tibco_401/tibcojre/1.6.0/bin/server/jvm.dll
tibco.env.JVM_LIB_DIR=C:/tibco_401/tibcojre/1.6.0/bin/client
Resolution:
=========
Define the correct for the three JVM settings as above.