Products | Versions |
---|---|
TIBCO BusinessConnect | - |
Not Applicable | - |
Resolution:
Description:
=========
When BC receives inbound data from a trading partner, it forwards the data to the private process as a binaryRequest in a SEND_TO_PP message. Why is BC sending the inbound message data as a binaryRequest instead of plainRequest to private process?
Environment:
===========
BusinessConnect all versions
Symptoms:
=========
The inbound data is passed as a as binaryRequest in the message (SEND_TO_PP) that is forwarded to a private process and the plainRequest field is passed as null (no content).
Cause:
======
The message content contains non ASCII/ISO-8859-1 characters.
Resolution:
=========
When the message is received, BC checks it for non ASCII/ISO-8859-1 content, specifically the first two hundred (200) bytes. If the message has non-ASCII/ISO-8859-1 content then BC considers it as binary. Otherwise, BC considers the data as a text request and forwards the message (SEND_TO_PP) to the private process. If BC gets an inbound file with zero bytes in size then BC considers this file by default as binary.