Products | Versions |
---|---|
TIBCO Service Gateway for DB2 | - |
Not Applicable | - |
Resolution:
After installing or upgrading to TIBCO Service Gateway™ for DB2 Release 5.2.0, customers accessing DB2 tables may suffer conversion failures on DB2 date fields. The same configuration and tables work successfully with previous versions of the product.
Environment:
============
The date conversion failure will happen under the following circumstances:
1) the DB2 system is configured for a local, non-standard date format such as "DD/MM/YYYY". [Standard date formats not affected by this problem include: ISO (YYYY-MM-DD), EUR (DD.MM.YYYY) or USA (MM/DD/YYYY).]
2) the Object Service Broker has also been customized through USERMOD1 to use the same date non-standard date format such as "DD/MM/YYYY" as DB2.
3) TIBCO® Service Gateway™ for DB2 5.2.0
4) TIBCO® Object Service Broker
Symptoms:
=========
The typical symptom will include the message:
"S6BD2051E HDB2SEL: CONVERSION ERROR on field field_name: Source field contains invalid data while processing date field"
when a DB2 table is accessed with a Date type field defined. This message will appear on the TIBCO Service Gateway™ for DB2 gateway JES log as well as being reported to the client session accessing the DB2 table.
Cause:
======
The date conversion error S6BD2051E is caused by a program error. If you are experiencing this issue, please open a service request with TIBCO Support and request to be put on the interested parties list for a resolution of "SGDB-83".
Resolution:
===========
"SGDB-83" requests a fix for this issue.
References:
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IBM DB2 Administration Guide
IBM DB2 SQL Reference
TIBCO Service Gateway™ for DB2 Installing and Operating Software Release 5.2.0
TIBCO® Object Service Broker for z/OS Installing and Operating Software Release 5.2.0