Runtime Error in DatabaseSupport.svc with "ActiveX Automation error Server could not be found error"

book

Article ID: KB0074286

calendar_today

Updated On:

Products Versions
Spotfire Statistica 12.7 and later versions

Description

Users who use Citrix and try to use the WritetoDatabase Node see the error "Runtime Error in '*DatabaseSupport.svc'(line334): Activex Automation :server could not be found.

Cause:

The DatabaseHelper.BulkWriter class is instantiated conditionally depending on how many rows are being written back to the database.  The error indicates there is a failure to initialize that class.

Resolution

The DatabaseHelper.Bulkwrite class is a .NET 2 based library. We can resolve the error by re-registering this class. To re-register the class :  

1. Launch cmd.exe as an administrator (elevated Command prompt). 
2. Browse to the Statistica installation directory 
3.  On a 64-bit machine, register the class with the command :

         C:\windows\microsoft.net\Framework64\v2.0.50727\RegAsm.exe /codebase /tlb DatabaseHelper.dll

     On a 32-bit machine, register the class with the command:

         C:\windows\microsoft.net\Framework\v2.0.50727\RegAsm.exe /codebase /tlb DatabaseHelper.dll

              RegAsm



 

Issue/Introduction

Runtime Error in DatabaseSupport.svc with "ActiveX Automation error Server could not be found error"