Unable to Login MDM UI after installing ECM.ear on 8.3.2 for Websphere Application server

book

Article ID: KB0081973

calendar_today

Updated On:

Products Versions
TIBCO MDM 8.3.2

Description

After Installing ECM.ear file of MDM 8.3.2 on Websphere application server unable to access MDM UI and getting response as Application unavailable; may have failed to start correctly. Contact system administrator.
We can see some exceptions from the logs which is related to JMX during startup.

JAV-8001: Unexpected error. Class: 'com.tibco.mdm.admin.hotdeployment.JmxHotdeploymentService' and method name: 'StartService'. Additional information: java.io.IOException: Cannot bind to URL [rmi://NHGDKMSVRAPP01.nhg.local:57571/Member1]: javax.naming.NameAlreadyBoundException: Member1 [Root exception is java.rmi.AlreadyBoundException: Member1].

java.io.IOException: Cannot bind to URL [rmi://NHGDKMSVRAPP01.nhg.local:57571/Member1]: javax.naming.NameAlreadyBoundException: Member1 [Root exception is java.rmi.AlreadyBoundException: Member1] 
	at javax.management.remote.rmi.RMIConnectorServer.newIOException(RMIConnectorServer.java:815) 
	at javax.management.remote.rmi.RMIConnectorServer.start(RMIConnectorServer.java:428) 

Environment

MDM + WEBSPHERE + ORACLE

Resolution

This is observed due to the invalid Security Provider and Application Server type provided in configvalues.xml file.
For Websphere Application server Valid Security Provider type is 'IBM'
 
<Category description="Security provider setup" isHidden="true" name="Security Provider" visibility="Basic">
<Group typeName="SecurityProviderType" typeValue="IBM">
<Item isActive="true" name="WEBSPHERE">
                    <ConfValue description="The name of the application server. If the value is Websphere, it is the Websphere application server." isHotDeployable="false" name="Application Server Name" propname="com.tibco.cim.appserver.name" readonly="true" sinceVersion="7.0" visibility="Basic">
                        <ConfString default="WEBSPHERE" value="WEBSPHERE"/>
                    </ConfValue>

Issue/Introduction

Tibco MDM Web login getting error after installing ECM.ear for 8.3.2 Error message: Application unavailable; may have failed to start correctly. Contact system administrator.