What happens when EMS is writing to disk and runs out of disk space, how does it behave?

book

Article ID: KB0092128

calendar_today

Updated On:

Products Versions
TIBCO Enterprise Message Service -
Not Applicable -

Description

Resolution:
If you run out of disk space while writing persistent messages to disk you will get a “SEVERE ERROR” with an I/O exception on the EMS server log. The error could be differently worded for failsafe and non failsafe destinations.

On the other hand the client application would throw “javax.jms.JMSException: Failure storing message” kind of error message. Messages should not be lost if you are using Persistent delivery mode on a failsafe destination with disk caching disabled.

Issue/Introduction

What happens when EMS is writing to disk and runs out of disk space, how does it behave?