TIBCO Enterprise Administrator(TEA) 2.2 server start up throws "unknown host" error on Mac OS X.

book

Article ID: KB0092417

calendar_today

Updated On:

Products Versions
TIBCO Enterprise Administrator (TEA) -
Not Applicable -

Description

Description:
New installation of TIBCO Enterprise Administrator(TEA) 2.2 server on Mac OS X, throws the following error in tea.log when starting the TEA server. 


ERROR MachineUtil [  ] Unable to get host address
java.net.UnknownHostException: trentsch-MBP15: trentsch-MBP15: nodename nor servname provided, or not known

Caused by: java.net.UnknownHostException: trentsch-MBP15: nodename nor servname provided, or not known

Symptoms:
TEA Server do not start
Cause:
UnknownHostException

Resolution

To resolve the issue,   /private/etc/hosts file should be modified to machine name.

Issue/Introduction

TIBCO Enterprise Administrator(TEA) 2.2 server start up throws "unknown host" error on Mac OS X.

Additional Information

http://crunchify.com/getting-java-net-unknownhostexception-nodename-nor-servname-provided-or-not-known-error-on-mac-os-x-update-your-privateetchosts-file/