ASMM unable to connect to metaspace due to the exception, "Exception while dispatching incoming RPC call".

book

Article ID: KB0093648

calendar_today

Updated On:

Products Versions
TIBCO ActiveSpaces -
Not Applicable -

Description

Description:
ASMM unable to connect to metaspace due to the exception, "Exception while dispatching incoming RPC call".

Symptoms:
ASMM unable to connect to metaspace due to the following exception messages.

=======================================

2015-03-26 10:12:34.993:WARN:/:Exception while dispatching incoming RPC call

com.google.gwt.user.server.rpc.UnexpectedException: Service method 'public abstract java.lang.Boolean com.tibco.as.admin.shared.service.ActiveSpa

cesAdminService.connectToMetaspace(com.tibco.as.admin.shared.data.control.ConnectToMetaspaceRequest)' threw an unexpected exception: java.lang.No

ClassDefFoundError: Could not initialize class com.tibco.as.space.impl.NativeImpl

        at com.google.gwt.user.server.rpc.RPC.encodeResponseForFailure(RPC.java:385)

        at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:588)

        at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall(RemoteServiceServlet.java:208)

        at com.google.gwt.user.server.rpc.RemoteServiceServlet.processPost(RemoteServiceServlet.java:248)

        at com.google.gwt.user.server.rpc.AbstractRemoteServiceServlet.doPost(AbstractRemoteServiceServlet.java:62)

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

        at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)

        at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:401)

        at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)

        at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)

        at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)

        at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:450)

        at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)

        at org.mortbay.jetty.Server.handle(Server.java:326)

        at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)

        at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:945)

        at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:756)

        at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)

        at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)

        at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:410)

        at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)
=========================================
 

Cause:
When mixed version of 32 or 64-bit TIBCO product stack with Java JRE will cause this issue.

Resolution

Guide lines for ASMM.


1). If you install 64-bit ActiveSpaces TIBCO stack, you should use the 64-bit Java JRE /SDK.


2).  If you install 32-bit ActiveSpaces TIBCO stack, you should use 32-bit Java JRE /SDK.


Mixed versions will cause exceptions such as "dispatching incoming RPC call".

Issue/Introduction

ASMM unable to connect to metaspace due to the exception, "Exception while dispatching incoming RPC call".

Additional Information