| Products | Versions |
|---|---|
| TIBCO BusinessEvents Enterprise Edition | 6.4.0 hotfix-02 |
Please follow the instructions below to download the hotfix:
1. Log in to the TIBCO Support Portal at (https://support.tibco.com) using your credentials.
2. Once logged in, navigate to "Downloads" -> "Hotfixes," then go to /AvailableDownloads/BusinessEvents/EnterpriseEdition/6.4.0/hotfix-02 to download the hotfix.
Alternatively, you can use the direct portal link to download Hotfix-11.
BE 6.4.0 hotfix-02 Direct Download Link: BE 6.4.0 hotfix-02 Direct Download Link
======================================================================================
Closed Issues in 6.4.0_HF-002 (This Release)
BE-36598
In TIBCO BusinessEvents (BE) versions 6.4.0, the CacheAgent fails to start if
you enable preloading and a concept's external ID (extId) or string key contains
a pipe (|) character. The system throws an "Invalid representation of Id"
runtime exception.
If you disable preloading, the InferenceAgent fails when it attempts to load
the affected parent concept.
This issue primarily impacts users migrating from earlier BE versions
(for example, 6.2.x to 6.4.0) and rely on preloading for performance optimization.
To resolve this issue, the fromString() method now correctly parses the key
portion of the ID. In this method, it first splits off the leading typeId segment.
The method then processes the remaining key portion using the registered IdProperties.
This change allows extId values and keys to contain pipe (|) and equals (=) characters
without causing parsing errors. The fix does not alter the persisted data format.
======================================================================================
All Supported Platforms
Please contact the TIBCO Support team if you have any trouble downloading the hotfix or if you have additional questions.
TIBCO BusinessEvents Enterprise Edition 6.4.0 Hotfix-02 is available
readme file