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Article ID: KB0070604
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Updated On:
Description
When switching the domain name style from DNS to Netbios (or vice versa), Spotfire Server throws Oracle errors.
Symptoms:
Tools.log file captures the errors:
===
.... config.tool.ConfigApp: Error executing command switch-domain-name-style
com.spotfire.server.config.tool.CommandException: Error updating the domain name names: Failed to update domain names
......
Caused by: com.spotfire.server.userdir.DirectoryException: Failed to update domain names
at com.spotfire.server.userdir.AbstractDatabaseProvider.switchDomainNameStyle(AbstractDatabaseProvider.java:2516)
at com.spotfire.server.userdir.UserDirectoryImpl.switchDomainNameStyle(UserDirectoryImpl.java:1807)
at com.spotfire.server.config.tool.SwitchDomainNameStyleCommand.run(SwitchDomainNameStyleCommand.java:63)
... 3 more
Caused by: java.sql.SQLIntegrityConstraintViolationException: ORA-00001: unique constraint (SPOTOWNER.USERS_NAME_DOMAIN_UIDX) violated
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Cause:
This issue can happen if the Spotfire Server service is started after importing the modified configuration file (with changes to domain name style) to Spotfire database but before running the "switch-domain-name-style"command. If the server is restarted, it will cause a new synchronization to be made, adding all users with the new domain name style, after which the existing accounts could not be changed, because that would generate duplicates.
Resolution
Here is a workflow for making these changes:
- Configure TIBCO Spotfire Server to use Netbios as domain name style (or viceversa).
- Make sure users are synchronized and they are able to login into Spotfire.
- Change the domain name style to DNS using the Configuration Tool and save configuration to Spotfire Database.
- Run switch domain name style command.
- Start the Spotfire Server service.
If the server is restarted before running the "switch-domain-name-style" command, the Spotfire Database will have users populated with both DNS and Netbios style. Unfortunately, there is no easy way to rectify this. One possible workaround would be the following:
- Stop the Spotfire Server Service.
- Make a backup of the Spotfire database.
- From the users table, delete all the users with the Netbios domain name style or the one's with DNS style.
- From the Configuration tool, change the domain name style to DNS or Netbios and import the updated configuration to Spotfire Database.
- Run the switch-domain-name-style command.
- Start the Spotfire Server Service.
Note that the same issue can also happen when using other database types for the Spotfire Database. However, the error messages may be different.
Issue/Introduction
Oracle errors when executing "switch-domain-name-style" command in Spotfire
Additional Information
How to remove "stuck" (or duplicate) users after corrupt LDAP sync
Duplicate user accounts with different domain names are seen in "Users & Groups" view of the Administration console after LDAP is synchronized
How to remove disabled synchronized users from TIBCO Spotfire