Products | Versions |
---|---|
TIBCO Administrator | - |
Not Applicable | - |
Resolution:
Description:
==========
Application deployment using TIBCO Administrator GUI fails intermittently. Here, in Administrator GUI, we don't see any error/exception however the following exception can be seen in Administrator logs:
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Error [Administrator] AESDKJ-0000 [http-8100-Processor14] java.lang.RuntimeException: java.net.SocketTimeoutException: Read timed out
at com.tibco.wfc.util.ServletUtils.getParameterParser(ServletUtils.java:29)
at com.tibco.wfc.FrameManager.if(FrameManager.java:306)
at com.tibco.wfc.FrameManager.service(FrameManager.java:129)
at com.tibco.administrator.AdministratorServlet.service(AdministratorServlet.java:957)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
at org.apache.catalina.servlets.InvokerServlet.serveRequest(InvokerServlet.java:420)
at org.apache.catalina.servlets.InvokerServlet.doPost(InvokerServlet.java:170)
----------------------
Deployment through AppManage goes fine every time.
It seems that upload is taking more time. Increasing java.property.tra_deploy_timeout in domain administrator and hawkagent tra files doesn't seem to be helping here.
Environment:
==========
TIBCO Administrator: 5.7.x
TIBCO Runtime Agent: 5.7.x
Cause:
======
Generally, "java.net.SocketTimeoutException: Read timed out" exception can occur while uploading a large file in Admin GUI.
Workaround:
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If the issue persists after increasing the java.property.tra_deploy_timeout in domain administrator and hawkagent tra file then try increasing the connectionTimeout value in server.xml to 200000 and check if it resolves the issue. You can perform following steps for this:
1). On administrator machine, go to <TIBCO_HOME>/administrator/domain/<domain_name>/tomcat/conf/ and take a backup of server.xml file.
2). Look for the connector port that administrator uses and increase the value of 'connectionTimeout'. For example, here admin is using 8097 port (i.e., Admin GUI can be accessed by http://<hostname>:8097) so modify connectionTimeout from default value 20000 to 200000:
i. e. <Connector port="8097" maxHttpHeaderSize="8192" maxThreads="150" minSpareThreads="25" maxSpareThreads="75" enableLookups="false" redirectPort="8443" acceptCount="100" connectionTimeout="20000" disableUploadTimeout="true"/>
To
<Connector port="8097" maxHttpHeaderSize="8192" maxThreads="150" minSpareThreads="25" maxSpareThreads="75" enableLookups="false" redirectPort="8443" acceptCount="100" connectionTimeout="200000" disableUploadTimeout="true"/>
3). Restart domain administrator and hawkagent.
4). Try deploying ear again and check if the issue has been resolved.