Products | Versions |
---|---|
TIBCO MDM | - |
Not Applicable | - |
Resolution:
Description:
============
The following error is seen when starting up the Netrics/Patterns server:
CFG-6020 TEXT SEARCH netrics svrnoop(): IO Error while connecting to primary server and backup is not configured. Make sure that the netrics servers are up and can be contacted from this server.: (Undefined).
Environment:
===========
TIBCO Master Data Management (MDM) All Environments
Cause:
=====
This error is generally thrown when the Host/Machine name in <Connection> parameter of IndexerConfig.xml (under $MQ_HOME\config directory) is incorrect.
Resolution:
==========
Specify the correct machine name in IndexerConfig.xml. For example:
<Server clusterIndex="1" backupIndex="1">
<Name>server1</Name>
<Connection>localhost:5051</Connection>
</Server>
In the above example, Netrics server is running on port 5051 on localhost.
References:
==========
System Administrator’s Guide -> Chapter 7 Search and Matching : Setup and Configuration section.