TIBCO Spotfire Web Player shows an old version of a report.

TIBCO Spotfire Web Player shows an old version of a report.

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Article ID: KB0073432

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Updated On:

Products

Spotfire Web Player

Description

TIBCO Spotfire Web Player shows an older version of a report which was recently updated. Even after re-saving the analysis and reopening it in the Web Player, it continues showing the older version.

Symptoms:
1. Web Player shows an older version of a report which was recently updated.
2. Re-saving the analysis in the Professional/Analyst client and re-opening it in the Web Player does not resolve the issue.

Cause:
The Web Player has a cached version of the report loaded and is not yet showing the newly updated version. 

Issue/Introduction

TIBCO Spotfire Web Player shows an old version of a report.

Resolution

The cached version of the report will eventually be invalidated and the new version will be displayed, but in order to force the updated version to be immediately displayed, restart either Internet Information Services (IIS) or the TIBCO Spotfire Web Player application pool.

Warning: This will close any active sessions and will restart the Web Player application which will clear all cached data, including data cached in Scheduled Updates.

The TIBCO Spotfire Web Player application pool can be restarted in the following way:
1. Select Windows Start menu > Administrative Tools > Internet Information Services (IIS) Manager.
2. Select Local computer > Application Pools.
3. Select the TIBCO Spotfire Web Player Pool.
4. Click Stop.
5. After the pool has stopped, click Start.

For more information about restarting IIS or application pools, please refer to the Microsoft IIS documentation.