How to force a Statistica workspace with the PI Asset Framework node (and other PI nodes) to work as a scheduled MAS tasket when the MAS service account does not have access to the OSI PI database?

How to force a Statistica workspace with the PI Asset Framework node (and other PI nodes) to work as a scheduled MAS tasket when the MAS service account does not have access to the OSI PI database?

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Article ID: KB0072109

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Updated On:

Products Versions
Spotfire Statistica 14.0 and above

Description

Monitoring and Alerting Server (MAS) would not run a workspace which connected to a OSI PI database, using any of the built-in PI nodes, when scheduled to run.  It would run successfully when ran interactively.  

Cause:
When submitting a scheduled task in MAS, if the account which runs the service (MAS service account) does not have permissions to access the database or the PI database login is different from the MAS service account, the task will fail.

For example, when using the PI Asset Framework node, credentials are required to access the OSI PI database.  However, the credentials used are the MAS service account, which may not have permissions to access the OSI PI database or the account with permissions to access the OSI PI database is different than the MAS service account.  

In the case, the PI Asset framework node does connect, interactively, but the OSI PI user credentials must be added in the prompt below:

PI Asset Framework

These credentials are stored in the Credential Manager:

Credentail Manager

However, when the task is scheduled, the task fails as the MAS service doesn't access the Credentail Manager.  

Environment

Windows operating systems only. Statistica Enterprise with MAS add-on.

Resolution

1.  Open the MAS Configuration tool, Start>>Statistica>>MAS Configuration
2.  Set LOAD USER PROFILE to 'True" 
3.  Click File>>Save

MAS Config - Load User Profile setting

Note:  The MAS Configuration tool may need to be launched as an Administrator.

Issue/Introduction

If the PI database login is different from the MAS Service account or the MAS service account does not have permission to the PI databse, then the Load User Profile will need to be enabled in the MAS Configuration tool and the credentials used need to be stored in the Credential Manager in order to successfully run a workspace as a scheduled task.

Additional Information

Release Notes : https://docs.tibco.com/pub/stat-all-servers/14.0.0/TIB_stat-all-servers_14.0.0_relnotes.pdf?id=1#page=17

Related article:  https://support.tibco.com/s/article/How-to-change-the-service-identity-for-COM-and-Windows-Service-for-the-Statistica-Monitoring-and-Alerting-Server