"Authentication failed" error when a new composite domain user attempts to login into Business Directory

"Authentication failed" error when a new composite domain user attempts to login into Business Directory

book

Article ID: KB0076982

calendar_today

Updated On:

Products Versions
TIBCO Data Virtualization All Supported Versions

Description

When a new "Composite" domain user is added in TDV and was granted"Access Directory" privilege for the TIBCO Business Directory , the login may fail with the "Authentication Failed".

Here is a screenshot for reference:

User-added image

Root cause:
The "composite" domains on each server (Business Directory and each TDV instance) are all completely independent of,
(1)   They don't share the user namespace
(2)   There is no co-ordination between servers.
Hence, a SITE name needs to be specified as the domain to help partition/address the specific users.
 

Issue/Introduction

"Authentication failed" error when a new composite domain user attempts to login into Business Directory

Resolution

Follow the steps below to resolve the issue:

1. Open the TIBCO Business Directory URL.
2. Enter the valid username and password.
3. In the domain field enter the SITE name instead of entering "composite". Example 'localhost_9400'
4. Click on Login.