TIBCO Spotfire Automation Services error:"Failure sending mail. Unable to read data from the transport connection: net_io_connectionclosed".

TIBCO Spotfire Automation Services error:"Failure sending mail. Unable to read data from the transport connection: net_io_connectionclosed".

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Article ID: KB0072657

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Updated On:

Products Versions
Spotfire Automation Services 7.0 and prior

Description

Description:
Automation Services throws an error when sending e-mail.

Error: "Failure sending mail. Unable to read data from the transport connection: net_io_connectionclosed".

Symptoms:
Spotfire.Dxp.Automation.log error entry:
---------------------------------------------------------------------------------
The task 'Send Email' could not be executed.
System.Net.Mail.SmtpException: Failure sending mail. ---> System.IO.IOException: Unable to read data from the transport connection: net_io_connectionclosed.
   at System.Net.Mail.SmtpReplyReaderFactory.ProcessRead(Byte[] buffer, Int32 offset, Int32 read, Boolean readLine)
   at System.Net.Mail.SmtpReplyReaderFactory.ReadLines(SmtpReplyReader caller, Boolean oneLine)
   at System.Net.Mail.SmtpReplyReaderFactory.ReadLine(SmtpReplyReader caller)
   at System.Net.Mail.SmtpConnection.GetConnection(ServicePoint servicePoint)
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   --- End of inner exception stack trace ---
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at Spotfire.Dxp.Automation.Tasks.SendEmail.SendTheMail(TaskExecutionContext context, String smtpHost, String fromAddress, String messageBody, AttachmentsInfo attachmentsInfo)
Done
------------------------------

Cause:
This error message indicates an issue connecting to the SMTP server.

Issue/Introduction

Error when using TIBCO Spotfire Automation Services: "Failure sending mail. Unable to read data from the transport connection: net_io_connectionclosed". This can happen if there are issues connecting to the SMTP server.

Resolution

This issue is related to connection to SMTP server so check if the application request (Automation Services) is being blocked on the SMTP server. Couple of checks you can perform are:

> Check if there is any communication problem between Automation Services server and SMTP server using "telnet"command from both machines.
> Ensure that Web/Automation Services Server (IP Address) has been added to the SMTP Relay.
Follow below steps for this on SMTP server machine:

- In Computer Management, drill down to the IIS branch.
- Select the Default SMTP Virtual Server.
- Right click Default SMTP Virtual server and select Properties
- On the General tab, change IP address to 'All Unassigned'.

Note: It is necessary to stop, and then start the SMTP service to ensure the changes take effect.