BUILD FAILED during the TIBCO BusinessWorks installation along with "could not open \tibcojre64\1.8.0\lib\amd64\jvm.cfg" error

BUILD FAILED during the TIBCO BusinessWorks installation along with "could not open \tibcojre64\1.8.0\lib\amd64\jvm.cfg" error

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Article ID: KB0075112

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks 6.x

Description


While installing the BW on Windows platforms the Installer is failing with below error(installation logs)

Note: This error can be seen with other TIBCO Products which are getting installed using TIBCOUniversalInstaller.exe

+++++++++++++
BUILD FAILED:
Error: could not open `G:\TibcoCE_2.4.4\tibcojre64\1.8.0\lib\amd64\jvm.cfg'
....

(09-18-2019.111717), ::ERROR::, Critical Exception during assembly installation: F:\TibcoCE_244\tibcojre64\1.8.0\bin\server\classes.jsa (The system cannot find the file specified), class com.tibco.installer.wizard.action.TIBCOInstallAssembliesWizardAction
(09-18-2019.111717), Debug,
java.io.FileNotFoundException: F:\TibcoCE_244\tibcojre64\1.8.0\bin\server\classes.jsa (The system cannot find the file specified)
++++++++++++++++++


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Issue/Introduction

Installation BUILD FAILED with could not open \tibcojre64\1.8.0\lib\amd64\jvm.cfg and classes.jsa files

Environment

Windows and Windows Server

Resolution

Root Cause:
This looks like a generic problem with Dynatrace. It always fails with java classes.jsa:
https://kb.informatica.com/solution/23/Pages/71/586676.aspx

If you look at the solution, it says:
The customer has to contact the Dynatrace vendor and disable it, or there will be an option to add the rule in Dynatrace so that it allows other applications to be installed.

According to TIBCO installation team, customer should contact Dynatrace support so they can get better information on this.

Workaround:
One way to avoid this error is to uninstall the Dynatrace OneAgent software from the machine and then try to install product again in a new TIBCO Home folder.

Note: We have observed that just stopping the OneAgent Service(no active process) does not resolve this problem.

Additional Information

You can refer to below URL for more details on Dynatrace tool:
https://www.dynatrace.com/support/help/setup-and-configuration/dynatrace-oneagent/

https://kb.informatica.com/solution/23/Pages/71/586676.aspx