Continuous timeout messages may occur while Upgrading TIBCO ActiveMatrix BPM

Continuous timeout messages may occur while Upgrading TIBCO ActiveMatrix BPM

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Article ID: KB0076398

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Updated On:

Products Versions
TIBCO BPM Enterprise (formerly TIBCO ActiveMatrix BPM) 4.2.0, 4.3.0

Description

Continuous timeout messages may occur while upgrading TIBCO ActiveMatrix BPM. This happens when starting child application process flow (PE) components. It is a post-upgrade task which TCT (TIBCO Configuration Tool) executes.

Symptoms:

TCT log will display continuously the timeout message - "Timed out waiting for components to be ((?!STOPPED).)*".

[echo] =================================================================
[echo] Task: Starting child app PE components
[echo] =================================================================
.
.
WARN - Timed out waiting for components to be ((?!STOPPED).)*
WARN - Timed out waiting for components to be ((?!STOPPED).)*
WARN - Timed out waiting for components to be ((?!STOPPED).)*
WARN - Timed out waiting for components to be ((?!STOPPED).)*
WARN - Timed out waiting for components to be ((?!STOPPED).)*

Cause:

BPM upgrade sends start commands for each of the child app ProcessFlow* components that are in the Stopped state. If this ProcessFlow component has been deleted in a later version, admin does not issue the start command to node runtime. This causes the timeout to continuously occur. 

Issue/Introduction

Continuous timeout messages may occur while Upgrading TIBCO ActiveMatrix BPM

Environment

ALL

Resolution

This issue has been fixed in AMX Platform 3.4.0 hotfix 2. 

Follow the below steps to apply this fix - 

1. Kill TCT process, if it is still running
2. Restore to a pre-upgrade backup
3. Apply 3.4.0 hotfix 2 or higher (refer 4.3.0 upgrade steps)
4. Re-run BPM upgrade

Additional Information

3.4.0 hotfix 2 announcement - https://support.tibco.com/s/article/Hotfix-TIB-amx-3-4-0-hotfix002-is-available-for-TIBCO-ActiveMatrix-R-BPM-4-3-0-and-TIBCO-Business-Studio-BPM-Edition-4-3-0 (Defect # AMX-17694)
4.3.0 upgrade steps - https://support.tibco.com/s/article/Recommendations-when-upgrading-TIBCO-ActiveMatrix-BPM-to-v4-3-0