Products | Versions |
---|---|
TIBCO BPM Enterprise (formerly TIBCO ActiveMatrix BPM) | 4.2.0, 4.3.0 |
Continuous timeout messages may occur while upgrading TIBCO ActiveMatrix BPM. This happens when starting child application process flow (PE) components. It is a post-upgrade task which TCT (TIBCO Configuration Tool) executes.
Symptoms:
TCT log will display continuously the timeout message - "Timed out waiting for components to be ((?!STOPPED).)*".
[echo] =================================================================
[echo] Task: Starting child app PE components
[echo] =================================================================
.
.
WARN - Timed out waiting for components to be ((?!STOPPED).)*
WARN - Timed out waiting for components to be ((?!STOPPED).)*
WARN - Timed out waiting for components to be ((?!STOPPED).)*
WARN - Timed out waiting for components to be ((?!STOPPED).)*
WARN - Timed out waiting for components to be ((?!STOPPED).)*
Cause:
BPM upgrade sends start commands for each of the child app ProcessFlow* components that are in the Stopped state. If this ProcessFlow component has been deleted in a later version, admin does not issue the start command to node runtime. This causes the timeout to continuously occur.