Database update failed after upgrading Statistica (Microsoft SQL Server)
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Article ID: KB0080786
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Updated On:
Products
Versions
Spotfire Statistica
12.0 and above.
Description
After upgrading Statistica to the latest version, or a newer version, successfully, the database update fails when launching Statistica.
Causes:
User used to connect to the enterprise/server metadata database does not have permissions to create tables.
The DSN connection information is set to use NT permissions instead of SQL user permissions.
Environment
Windows operating systems. MS SQL Server. Enterprise/Server-type installs.
Resolution
Attempt the solutions in order below:
SOLUTION ONE Using Windows NT authentication in the DSN connection may cause the error. Change to SQL Server authentication by re-configuring the DSN:
1. Go to Control Panel--> Administrative Tools--> ODBC Data Sources. Select the "System" tab, select the enterprise metadata database and click the "Configure" button.
2. Select the "With SQL Server authentication..." option and enter the SQL ID and password:
3. Continue through the configuration and click "Finish."
4. Launch Statistica and perform the database update again:
SOLUTION TWO The sysadmin (or dbcreator) in MS SQL databases has the permissions to create tables. To resolve this issue, temporarily add the Statistica database user to the sysadmin (or dbcreator) group:
1. With Microsoft SQL Management Studio, right click on the user and select "Properties." 2. Select "Server Roles" and check the "sysadmin" box:
3. Click the OK button.
4. Launch Statistica and perform the database update again:
Issue/Introduction
This article discusses a database failure after upgrading to the latest version of Statistica, when using SQL server, and provides the steps to resolve the failure.