ERROR "Open Analysis from Library failed" "The file '/XXXXX/XXXXX' could not be found in the library" when using (execute on server) in Automation Services

ERROR "Open Analysis from Library failed" "The file '/XXXXX/XXXXX' could not be found in the library" when using (execute on server) in Automation Services

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Article ID: KB0077841

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Updated On:

Products Versions
Spotfire Automation Services 7.5 and higher

Description

This article describes how to resolve the error, "Open Analysis from Library failed\nThe file '/XXXXX/XXXXX' could not be found in the library" when using "execute on server" in Automation Services

Symptoms:
- An attempt to execute an Automation Services task on a server fails, with this error: "Open Analysis from Library failed\nThe file '/XXXXX/XXXXX' could not be found in the library".
- Whereas Automation tasks/jobs on analysis files placed in the root folder of the Spotfire library execute as expected but tasks on analysis files placed in locations other than the root folder tend to fail.

Example:
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Error Message: You do not have sufficient privileges for this action
FAILED: Task 2 'Save Analysis to Library' failed with: Spotfire.Dxp.Framework.Library.LibraryException: You do not have sufficient privileges for this action. ---> Spotfire.Dxp.Services.Library.LibraryServiceException: You do not have sufficient privileges for this action.
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Cause:
This happens if the "automationservices@SPOTFIRESYSTEM" account does not have the permissions necessary for this task on the specific Spotfire library folders that contain the analysis and the Information Services elements (such as information links, data sources, columns, joins, and filters) it uses.

Issue/Introduction

ERROR "Open Analysis from Library failed" "The file '/XXXXX/XXXXX' could not be found in the library" when using (execute on server) in Automation Services

Environment

All supported operating systems

Resolution

Ensure you have assigned licenses required by the Automation Services jobs to the automationservices@SPOTFIRESYSTEM user, which is the account used to execute the jobs on the service instance. You have also given the user the appropriate read and write access to the library for the data required by the Automation Services tasks, and the job files.

To resolve this issue, follow the steps below.

-  Login to Spotfire Analyst as a Spotfire administrator.
-  Click on the Tools menu.
-  Click on "Library Administration".
-  Highlight the folder which contains the report that is failing.
-  Click EDIT in the "Permissions for Selected Folder".
-  Search the user "automationservices@SPOTFIRESYSTEM". 
-  Grant Browse+ Access + Modify permissions.
-  Click OK.

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Additional Information

https://docs.tibco.com/pub/spotfire_server/10.3.1/doc/html/TIB_sfire_server_tsas_admin_help/GUID-14533D5E-426E-4837-A80A-16E75D185FD7.html