Products | Versions |
---|---|
Spotfire Statistica | 8.0 up to 13.2. |
When installing Statistica, registration may fail and the following error is displayed:
For 13.3.x and above, the error displayed is:
CAUSE 1
The communication channel between the computer and registration server is blocked.
CAUSE 2
Internet Explorer 7 (or higher) is not installed. The Statistica installer uses Internet Explorer components so it MUST be installed and TLS 1.0 MUST be enabled.
RESOLUTION 1
Unblock the communication channel caused by one or more of the following:
1. Firewalls-- (both software firewall(s) or hardware firewalls, e.g., inside a router, gateway, or a standalone appliances like SonicWall ) please temporarily disable any installed firewall applications. (Note: Two or more firewalls may be installed and running)
Firewalls can be either software or hardware.
SOFTWARE
Windows includes a firewall but others can be installed and run simultaneously with the Windows Firewall. Typically all security suites have a firewall built in to them as well. Trend Micro, Kasperkey, Symantec (Norton), McAfee, G-Data, Avast all have security suites with firewalls built in to them. The above security suite list is not exhaustive.
HARDWARE
Hardware firewalls are built in to routers, gateways, modems, and appliances that just contain firewalls (e.g., SonicWALL).
2. Anti-virus or anti-spyware -- please temporarily disable any installed antivirus or anti-spyware applications (or any anti-malware software). Disable any security suites temporarily as well.
3. Network restrictions-- the computer is attached to a network which has restrictions to some websites (e.g. a proxy server may block outgoing communication). This is especially common on corporate networks. For example, any proxy service or automatic configuration script will block registration:
If possible, discontinue using the proxy server while installation Statistica.
4. If unable to bypass proxy server, add the following information to its configuration
To test the communication channel between the computer and registration server, run the Automatic Registration Tester application, attached to this knowledge base article below. (To run, download or save the AutoRegTester.ex_, right-lick and rename AutoRegTester.exe. Doubloe-click to run).
1. Click the "Begin Test" button to test:
2. After the test completes, the "Show Log" button will be active. Click to view the log. The example below shows communication successful:
RESOLUTION 2
Download and install Internet Explorer 7 or later. To see which versions of Internet Explorer on compatible with each Microsoft operating system, see this list here. TLS should be enabled by default but this can be check by clicking on Start | Control Panel | Network and Internet | Internet Options: