Error while running the "hotfix.bat" script: "This app can't run on your PC" or "access denied."

Error while running the "hotfix.bat" script: "This app can't run on your PC" or "access denied."

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Article ID: KB0078202

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Updated On:

Products Versions
Spotfire Server 7.5 and higher

Description

When executing the "hotfix.bat" script or running this from a command line, Spotfire Administrators may see the following error (s)

Error when running the batchfile directly:    "This app can't run on your PC."

Error when running from the Command Line:   "Access denied."

Cause:
These errors can be thrown as a result of the "java.exe" file under "Installation Drive:\tibco\tss\Spotfire Version\jdk\bin\" getting corrupted.

Sometimes, the "java.exe" file under "Spotfire Server installation folder\\jdk\bin\" shows its size as 0 bytes. The time stamp on this "java.exe" file will also show an older time. This will lead to the "hotfix.bat" file not getting executed. 

Issue/Introduction

Error while running the "hotfix.bat" script: "This app can't run on your PC" or "access denied."

Environment

All supported environments

Resolution

To resolve this issue, the "hotfix.bat" file should be pointed to "jdk\jre\bin\java.exe" under the Spotfire Server installation directory, as follows.

1) Navigate to the folder where the server hotfix is downloaded and edit the "hotfix.bat" file in a text editor.

2) Go to the section where it says "java". Update it with the following path:

    Installation Drive:\tibco\tss\Spotfire Version\jdk\jre\bin\java.exe

The following example is for a Spotfire Server 7.11.0 instance that has been installed on the C: drive of a Windows server:
  
    c:\tibco\tss\7.11.0\jdk\jre\bin\java.exe
 
Note: Change the drive and folder names according to how it is in your installation.

3) Save and close the "hotfix.bat" file. 

4) Launch the Command Prompt as an administrator.

5) Navigate to the folder where "hotfix.bat" is present (the updated one).

6) Type in "hotfix.bat" and press the <Enter> key. It will ask for the Spotfire installation directory. Assuming the above installation path was correct, the following location should be entered:

    c:\tibco\tss\7.11.0\

User-added image

Alternatively, the corrupted "java.exe" file under "Spotfire Server installation directory\jdk\bin\" can be replaced with the working "java.exe" file so that it can be used to run the "hotfix.bat" file, without any error.

A working "java.exe" can be either copied from the "Spotfire Server installation directory\tss\7.11.0\jdk\bin\" of a working server instance of the same Spotifre version or from "Spotfire server installation directory\tss\7.11.0\jdk\jre\bin" of the same server instance.