Getting InvalidSignatureException while connecting to Amazon DynamoDB data source from the Composite studio.

Getting InvalidSignatureException while connecting to Amazon DynamoDB data source from the Composite studio.

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Article ID: KB0081732

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Updated On:

Products Versions
TIBCO Data Virtualization 7.0.X

Description

While connecting to the Amazon DynamoDB, if you are getting below error(s) related to #InvalidSignatureException" then follow the resolution section

============================================================
Error ["com.amazon.coral.service#InvalidSignatureException" "Signature expired: 20180531T100334Z is
    now earlier than 20180531T104048Z (20180531T105548Z - 15 min.)"-3961000]:  SQL State = null,
    SQL Error Code = 0
Cause: "com.amazon.coral.service#InvalidSignatureException" "Signature
    expired: 20180531T100334Z is
    now earlier than 20180531T104048Z (20180531T105548Z - 15 min.)"
=============================================================
Error ["com.amazon.coral.service#InvalidSignatureException" "Signature not yet current:
    20180531T114402Z is still later than 20180531T112826Z (20180531T111326Z + 15 min.)"-3961000]:
    SQL State = null,  SQL Error Code = 0
Cause:
    "com.amazon.coral.service#InvalidSignatureException" "Signature not yet current:
    20180531T114402Z is still later than 20180531T112826Z (20180531T111326Z + 15 min.)"
===============================================================


The above error(s) messages occur when your local machine clock i.e. Composite studio machine has time difference as compared to the AWS Server time.

Issue/Introduction

Getting InvalidSignatureException while connecting to Amazon DynamoDB data source from the Composite studio.

Environment

All Supported Operating Systems

Resolution

So to resolve the issue, you need to change sync the composite studio machine time with the server time and then relaunch the studio client.

You can manually change the machine time or can use any 3rd party utility like W32Time service, NTP etc. as well like to sync the machine time. If you are not able to change the machine time due to any group policy then get in touch with your system administrator.

Additional Information

https://stackoverflow.com/questions/44017410/signature-expired-is-now-earlier-than-error-invalidsignatureexception

https://docs.microsoft.com/en-us/windows-server/networking/windows-time-service/windows-time-service-tools-and-settings#w32tmexe-windows-time

https://www.meinbergglobal.com/english/sw/ntp.htm#ntp_stable