How to resolve "An error occurred: Permission Denied Code:0x80040504" in SDMS Administration utility?

How to resolve "An error occurred: Permission Denied Code:0x80040504" in SDMS Administration utility?

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Article ID: KB0073469

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Updated On:

Products Versions
Spotfire Statistica 10.0 - 13.5

Description

How to resolve "An error occurred: Permission Denied Code:0x80040504" in SDMS (Statistica Document Management System) Administration utility?

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Issue/Introduction

How to resolve "An error occurred: Permission Denied Code:0x80040504" in SDMS(Statistica Document Management System) Administration utility?

Resolution

Cause:
The user seeing the error is a SDMS user but not a System Administrator on SDMS

Resolution 1: If the use case is to view the system Settings / view the membership of SDMS Groups.
1. Click on STATISTICA Document Management (Root folder) on the left pane of Statistica
2. Click Logout
3. Click Login
4. Login with admin credentials or as a user who is part of the System Administrator group.
5. Review the System Settings/ SDMS Groups.
6. If no settings are shown, click Refresh to reload the view.

Resolution 2:If the use case is to add the user seeing the error as a system administrator.
1. Click on STATISTICA Document Management (Root folder) on the left pane of Statistica
2. Click Logout
3. Click Login
4. Login with admin credentials or as a user who is part of the System Administrator group.
5. Click Groups>>System Administrators and add the user who was seeing the error initially

Reference illustration of resolution :

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