How to resolve "Maximum connection limit exceeded" error?

How to resolve "Maximum connection limit exceeded" error?

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Article ID: KB0077200

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Updated On:

Products Versions
TIBCO Data Virtualization 7.0.6 and higher

Description

Users may see "Maximum connection limit exceeded" while logging into TDV studio.
The cs_server.log file may capture following entry :

ERROR [DbChannel-RequestSelectThread] 2019-02-11 11:02:54.783 -0500 RequestSelectThread - The connection limit of 100 has been exceeded.[dbchannel-1918008]
Caused by: com.compositesw.common.security.CompositeSecurityException: The connection limit of 100 has been exceeded.[dbchannel-1918008]  [dbchannel-1918008]

Root cause:
This occurs when the JDBC/ODBC/ADO.NET conncetion exceeds the configured value. At any given time, upto 100 connections are allowed in TDV Studio. If the number of connections exceeds this value, users may see the error.

 

Issue/Introduction

This article describes the reason for "Maximum connection limit exceeded" error and steps to resolve it.

Environment

All supported operating systems

Resolution

Follow the steps provided here to resolve this issue:

#1) Open TDV studio .

#2) Click on "Administration" in the tool bar and  browse  to "Configuration>>Server>>Client Drivers>>Session>>Maximum Session"  ( Default value is 100 ).

#3) Update this value according to the requirement.

#4) Apply the changes and click on OK. 

Note : There is no need to restart the TDV services for these changes to take effect.