How to resolve "Migration of SDMS content was only partially successful."?

How to resolve "Migration of SDMS content was only partially successful."?

book

Article ID: KB0074594

calendar_today

Updated On:

Products Versions
Spotfire Statistica 14.0
Spotfire Data Science - Workbench 1.3

Description

If SDMS was previously installed, with 14.0 there will arise a need to move SDMS Content to Statistica Enterprise meta database.

For the migration process, Portable Distribution tool (Statistica.Portable.Addon-14.0 and Statistica.Engine-14.0) is provided along with the Statistica 14.0 installer in edelivery.tibco.com. This Portable Distribution tool must be run only on the SDMS Server. During the migration, there may be certain SDMS objects that fail to migrate.

User-added image

Subsequently, we will also have the Result of SDMS data migration that implies that the migrations was only partially successful  :

User-added image

The logs may have errors such as : “Failed to get SDMS file handle:The system cannot find the file specified ”. Click No then you can go back to the previous screen and click Reset if you would like to try and address the items listed in failed objects

Root Cause:
The problem is that SDMS files for specific versions are missing. The file does not physically exist on the SDMS server. There are different causes to this problem. It is possible that one of the following events (cause) happened for IT upgrade or test activities. And it is very possible that the event could have happened years ago and did not impact use of the product.Here are some potential causes of the failed objects

 
  • A system administrator changed Statistica Enterprise Manager >> System Options >> SDMS Integration >> Path to keep objects. So now objects are stored in a different folder
  • A system administrator changed the Statistica Enterprise Manager>>System Options>>SDMS Integration>> Server URL (thereby object versions are stored on a different SDMS server)
  • A system administrator logged into the SDMS server and manually moved the SDMS files/folders.
  • New version of SDMS was released. IT administrator created a new server and started with a clean installation. The administrator did not copy all the SDMS files from the old server to the new server as detailed in : https://support.tibco.com/s/article/How-to-migrate-SDMS-from-one-server-to-another

Issue/Introduction

How to resolve "Migration of SDMS content was only partially successful." ?

Resolution

Solution 1:
If you go through listed failed objects and recognize a timeline where the SDMS Server was changed or the client changed the SDMS server and if you still have access to the old server, you could look for the Pathname of the failed objects (as detailed in:  https://support.tibco.com/s/article/How-to-find-the-physical-location-of-SDMS-files-associated-with-a-specific-object-in-Statistica-Enterprise ) and see if the files exist and copy the files over to the new server.

Re-run the Portable distribution Tool and click Yes to migrate to the newer versioning.If you would like to address more of the failed objects,click No then you can go back to the previous screen and click Reset.

Solution 2:
Evaluate if the files associated with the failed objects ( https://support.tibco.com/s/article/How-to-find-the-physical-location-of-SDMS-files-associated-with-a-specific-object-in-Statistica-Enterprise) are in another drive - i.e perhaps the results of the PATHNAME point to C:\ but the files were physically moved to E:\  due to lack of space at some point. Carefully evaluate if only the dive changed or if the path needs to change and execute a SQL such as
Update SDMDOCREVISIONS set pathname=Replace(PathName,'c:\','e:\') ;
Raise a support case on support.tibco.com if assistance is required with this step.

Re-run the Portable distribution Tool and click Yes to migrate to the newer versioning if there are no failed objects you want to address. If you would like to address more of the failed objects,click No then you can go back to the previous screen and click Reset.

Solution 3:
Evaluate if the failed objects are old and if you do not mind losing older versions of those objects. In this case, Statistica will start using the latest version of the object as the initial version of the object. Click Yes on the Result of Database Migration dialog and click Activate Now to finalize the migration of Versions.

User-added image