How to resolve "No response from Server at the specified URL" error during the login process in TIBCO Statistica?

How to resolve "No response from Server at the specified URL" error during the login process in TIBCO Statistica?

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Article ID: KB0074422

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Updated On:

Products Versions
Spotfire Statistica 12.0 and higher

Description

When users are unable to login to the Server from workstation/client. The following error occurs:

Server Client Error

Cause:

  • Server and workstations on different networks
  • Firewall block
  • Config.php settings are incorrect
  • Users are not members of the SWS_USER group

Issue/Introduction

Unable to login to Statistica Server through Statistica Server Client (workstation)

Environment

Windows operating systems only. Statistica Enterprise (or Statistica Server) installs.

Resolution

SOLUTION ONE:  Modifying server location settings

1.  On the server, in Statistica click File | Options, select Server/Web.

2.  Select Enable Statistica Server Integration and enter the server IP address (or the Fully Qualified Domain Name, FQDN) in the Host box, click the "OK" button:

Server configuration options

 

SOLUTION TWO:  Modify firewall rule for WebStatistica service

1.  Open Windows Firewall with Advanced Security, select Inbound Rules, and find the "WebStatistica Service":

WebStatistica service firewall settings

2.  Double-click to open Properties, select "Allow the connection" if not already selected, and click the Apply button:

WebStatistica Properties

Any IP not just Local IPs

 

Solution Three:   Changing the Config.php file

1.  Locate the Config.php configuraiton file.  Typical location is :\WebSTATISTICAPub\wwwroot\. 

2.  Open the Config.php with Notepad.

3.  Change the SOAP host to the IP address so that it matches the one in the Server/Web Options (Solution #1 above) between single quote marks:

config.php file

4.  Save the file (or save to another location and copy/paste into the original location):

SOAP changed to IP address

SOLUTION FOUR:  Making sure the port for WebStatistica matches the port in the WebStatistica Admin Tool and the Config.php file

1.   Open the Admin tool (may be labeled WebStatistica Admin Tool or Statistica Server configuration):

2.  Double-click the TCPIPPort setting and modify the port if it does not match the port number in the Config.php file (above) and click the OK button:

Port Modification


SOLUTION FIVE:  Add users to the SWS_USER Windows group

For users to login to the server via Statistica, they must be members of thw SWS_USER group.  This group was created when Statistica Server was installed.  
1.  Open Control Panel | Administrative Tools | Computer Management
2.  Expand Local Users and Groups and then Groups
3.  Add the users to the SWS_USERS group:
SWS_USER group