Node manager service may stop automatically when running with custom Windows account

Node manager service may stop automatically when running with custom Windows account

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Article ID: KB0081156

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Updated On:

Products Versions
Spotfire Web Player 7.5 and later

Description

Description:
Node manager service may stop automatically when running with custom Windows account. By default, it runs as the "Local System" account. Some users may want to use a custom account to run the service, which may not work and result in the below warning.

"Some services stop automatically if they are not in use by other services or programs".

Symptoms:
If the logon account for Node Manager service is changed from the default account to a custom Windows account, starting the service throws the following.
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Services
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The TIBCO Spotfire Node Manager 7.5 service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.
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OKĀ 
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Cause:
This occurs if the account running the Node Manager service does not have desired permissions on the Node Manager installation folder.

Issue/Introduction

Node manager service may stop automatically when running with custom Windows account

Resolution

Add the desired Windows account to "<Installation folder>\tibco\tsnm" and grant "Full control" permissions to it. After saving the changes, you should be able to start the service without any error/warnings.

Refer to the attached screen shot for reference.

Additional Information

https://docs.tibco.com/pub/spotfire_server/7.6.0/doc/html/TIB_sfire_server_tsas_admin_help/GUID-3237F847-3135-4F10-8284-1D66F6DEC36E.html
Home > Installation and configuration > Node manager installation

Refer the attached screen shot (Filename: Node_manager_folder_permissoins.pdf) for more information.