Not able to login AMX admin GUI

Not able to login AMX admin GUI

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Article ID: KB0071210

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Updated On:

Products Versions
TIBCO ActiveMatrix Service Grid 3.3.0

Description

The customer may face the issue of "not able to login to Activematrix Admin GUI" and see the below error in SystemNode logs.

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17 May 2018 22:46:46,548 [Start Level Event Dispatcher] [ERROR] [] com.tibco.amx.hpa.jca.Activator - TIBCO-AMX-HPA-014242: JCA start failed!
java.lang.UnsatisfiedLinkError: sun.security.ec.ECKeyPairGenerator.getEncodedBytes(J)[B
    at sun.security.ec.ECKeyPairGenerator.getEncodedBytes(Native Method)
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Root cause:

This was caused by an incorrect JRE library. Possibly some product installation updated the JRE libraries incorrectly

Issue/Introduction

Not-able-to-login-AMX-admin-GUI

Environment

All Supported OS Platforms

Resolution

1. Take a backup of the corrupted JRE folder (<tibco_home>\tibcojre, or <tibco_home>\tibcojre64).

2. Replace the corrupted JRE folder with a JRE folder from a working environment. Please make sure that the JRE byte mode (32-bit or 64-bit), version, and update number are the same in the working JRE folder, and make sure the new JRE has the same configuration as the OLD JRE (just like "java.security","cacerts" file under <JRE_Home>\lib\folder, etc).

3. Restart the environment and check if the user can log in to AMX Admin GUI successfully.