Promoting a user to Spotfire Administrator returns the error "Could not promote administrator"
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Article ID: KB0080682
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Updated On:
Products
Versions
Spotfire Server
All Versions
Description
This article provides a resolution for the error, "Could not promote administrator" which may occur while promoting a user to a Spotfire Administrator.
Symptoms:
1). The following error message appears while promoting a user to a Spotfire Administrator in the Configuration tool. ------------------------------------------------------------------ Could not promote administrator admin[abd90f78-e0a9-4fdc-b88c-b9b82b3a01c3] ------------------------------------------------------------------ Refer to the attached error screenshot (Filename: Error_promote_user.jpg) for reference.
2). The following error is logged in the server.log file under the Spotfire server logs. -------------------------------------------------------------------------------------------------------------- com.spotfire.server.ServerInitializationException: TIBCO Spotfire Server will not be started. Database consistency verification failed. Errors found: Incorrect number of views. Expected 1 but was 0 Missing views: UTC_TIME --------------------------------------------------------------------------------------------------------------
Cause:
The error, which is logged in the server.log file under the Spotfire server logs, indicates that UTC_TIME is missing in the Spotfire Database. This is most likely caused by a permission issue with the Spotfire Database user.
Issue/Introduction
Promoting a user to Spotfire Administrator returns the error, "Could not promote administrator".
Environment
All Supported Operating Systems
Resolution
The Spotfire Database user you specify needs to have “Create view” privilege. To fix this issue you need to manually create this view.
- Login to the Database with a user that has permissions to grant necessary privileges to the Spotfire Database user. - Once logged in, run the command "GRANT CREATE VIEW TO <DATABASE USER>". - Once the privilege has been granted to the Spotfire DB user you then need to login as the Spotfire Database user and create the view.
NOTE: You may need a DBA to grant necessary privileges to the Spotfire Database user.
Attachments
Promoting a user to Spotfire Administrator returns the error "Could not promote administrator"
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