TIBCO Spotfire Scheduled Update fails with error: "The file 'XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXX' could not be found or accessed."

TIBCO Spotfire Scheduled Update fails with error: "The file 'XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXX' could not be found or accessed."

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Article ID: KB0072256

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Updated On:

Products Versions
Spotfire Web Player 7.5 and higher

Description

Description:
This article describes how to resolve error, "The file 'XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXX' could not be found or accessed", when an analysis file is added in the scheduled update and it fails with this error.

Symptoms:
Unable to execute scheduled update after adding file in scheduled update and fails with the error , "The file 'XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXX' could not be found or accessed".

Cause:
This happens if the "scheduledupdates@SPOTFIRESYSTEM" account does not have proper library permissions on the folders in the Spotfire library.

Environment

All

Resolution

In Spotfire 7.5 and higher versions, scheduled updates are run by a predefined user account, "scheduledupdates@SPOTFIRESYSTEM". To resolve this issue, make sure that the account "scheduledupdates@SPOTFIRESYSTEM" has proper library permissions set to access analysis file(s) in the library as follows.

- Grant Browse+ Access permissions on folder(s) where analysis file(s) are saved that needs to add in scheduled update.
- Grant permission to access folder(s) that saved information link(s) for these analysis file(s).
- Grant permission to access folder(s) that saved Data source(s) for these analysis file(s).

Issue/Introduction

This article describes how to resolve error, "The file 'XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXX' could not be found or accessed", when an analysis file is added in the Scheduled Update in TIBCO Spotfire and it fails with this error.

Additional Information