TIBCO Spotfire Server fails to start after configuration of ActiveSpaces

TIBCO Spotfire Server fails to start after configuration of ActiveSpaces

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Article ID: KB0075888

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Updated On:

Products Versions
Spotfire Server 7.5 and above

Description

TIBCO Spotfire server fails to start after enabling  Active Space for clustering
Below is the error returned in "server.log" file:
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Caused by: com.tibco.as.space.ASException: INVALID_ARG (command_line_arg_invalid - -listen argument tcp://192.192.192.152:5701;10.97.111.152:5701;, none of the listen URL is available [10.97.111.152:5701 Security domain controller's listener url must be in discovery list: 10.97.111.152:5701 <=> tcp://10.97.111.152:5702;10.97.111.17:5701])

  at Native.MemberManager::init(MemberManager.cpp:184)
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OR 
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[*Initialization*] server.cluster.RetryHelper: Function execution failed. Retry count: 0

java.lang.RuntimeException: com.tibco.as.space.ASException: INVALID_ARG (command_line_arg_invalid - -listen argument tcp://10.97.111.17:5701;192.192.192.17:5701;, none of the listen URL is available [192.192.192.17:5701])

  at com.spotfire.server.cluster.ActiveSpacesClusterInstanceBase.connectMetaspace(ActiveSpacesClusterInstanceBase.java:136)
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Possible causes:
1) Port number or the  Server url  used in the policy file is incorrect
2) Same bootstrap file is copied to all the Spotfire servers in the cluster 
 

Issue/Introduction

Caused by: com.tibco.as.space.ASException: INVALID_ARG (command_line_arg_invalid - -listen argument tcp://servername1:node;servername2:portnumber;, none of the listen URL is available [servername1:portnumber Security domain controller's listener url must be in discovery list: servername:portnumber)

Environment

All supported Windows Operating systems

Resolution

Solution for cause 1:
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a) Check the port number used in the Spotfire Server configuration and make sure the policy file is also using the same port number  e.g Check the screenshot of the Spotfire Server configuration where the port number is 5701 and should match the Port number in the <Spotfire Server install>nm\trust\as_policy.txt


From as-polict.txt >> metaspace_access=metaspace=spotfire;discovery=tcp://10.97.111.152: 5701;10.97.111.17: 5701

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Solution for cause 2:
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e.g. for  metaspace_access=metaspace=spotfire;discovery=tcp://10.97.111.152:5701;10.97.111.17:5701

10.97.111.152 is the IP address of server 1 and  10.97.111.17 is the IP address of server 2 in the cluster.

Make sure you have created a unique bootstrap file for each server in the cluster as the bootstrap file has the local server name ,IP address and a unique Server ID associated for  each server and this information is also stored in the Spotfire Database. If the same file is copied Server will fail to start.
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Additional Information