TIBCO Spotfire Server stops working if Server hotfix is applied without stopping the Spotfire Server service.

book

Article ID: KB0077826

calendar_today

Updated On:

Products Versions
Spotfire Server All Versions

Description

Description:
This article describes the resolution for below error in the "server.log".
----------------------------------------------

web.context.ContextLoader: Context initialization failed
java.lang.IncompatibleClassChangeError: class org.springframework.core.LocalVariableTableParameterNameDiscoverer$ParameterNameDiscoveringVisitor has interface
org.springframework.asm.ClassVisitor as super class
-----------------------------------------------

Symptoms:
Unable to browse Spotfire server Admin Console URL.
 
The following error is seen in the file "<install directory>\tomcat\logs\Server.log".
-------------------------------------------------------
web.context.ContextLoader: Context initialization failed
java.lang.IncompatibleClassChangeError: class org.springframework.core.LocalVariableTableParameterNameDiscoverer$ParameterNameDiscoveringVisitor has interface

org.springframework.asm.ClassVisitor as super class
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2957)
    at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1210)
    at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1690)
    at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1571)
-------------------------------------------- 

Cause:
This issue occurs if Spotfire Server service is not stopped when applying a hotfix.

Resolution

Re-apply the hotfix as follows:

1) Stop the TIBCO Spotfire Server.

2) Run the hotfix utility.

3) Start the TIBCO Spotfire Server.

It is recommended to stop the Spotfire server service before applying the hotfix.

Issue/Introduction

TIBCO Spotfire Server stops working if Server hotfix is applied without stopping the Spotfire Server service.

Additional Information

Read "Installation_Instructions.htm" in the downloaded hotfix folder.

How to Apply a TIBCO Spotfire Server Hotfix:
https://www.youtube.com/watch?v=KnHEfw3Foj8