Advisory message: "_RV.ERROR.SYSTEM.DATALOSS.OUTBOUND.PTP"

Advisory message: "_RV.ERROR.SYSTEM.DATALOSS.OUTBOUND.PTP"

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Article ID: KB0092140

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Updated On:

Products Versions
TIBCO Rendezvous -
Not Applicable -

Description

Resolution:
Client programs receive the advisory message "_RV.ERROR.RV.DATALOSS.OUTBOUND.PTP" when a transmission request between RVD processes fails: clients of the sending daemon receive DATALOSS.OUTBOUND advisories while clients of the receiving daemon receive DATALOSS.INBOUND advisories.  DATALOSS advisories indicate network transmission problems.

Sending daemons retain outbound messages for 60 seconds.  If a receiving daemon detects that it missed an inbound message, it requests retransmission from the sending daemon.  If 60 seconds have elapsed, the sending daemon has already discarded the message, and so is unable to retransmit.

Under normal operating conditions, both daemons notify all their clients that data has been lost.

.PTP indicates that a point-to-point message was lost.

.BCAST indicates that a broadcast message was lost.

Daemons are unable to determine which clients are affected by the data loss so these advisories are delivered to all clients, although all may not have lost the data.

Causes:
There can be several causes for the receipt of these advisories, such as,

- Some hardware component is experiencing intermittent failure i.e. faulty network card, loose connection, frayed wire....

- The network can be overloaded.

- A daemon process is starved for CPU cycles i.e. computer is too heavily loaded, or the priority of the daemon process is too low.

- The daemon is running with a "-reliability" parameter lower than 60 seconds.

For further information on System Advisory Messages please refer to Appendix A of the Concepts manual.


Issue/Introduction

Advisory message: "_RV.ERROR.SYSTEM.DATALOSS.OUTBOUND.PTP"

Environment

Product: TIBCO Rendezvous Version: All OS: All --------------------