JMSXDeliveryCount does not appear although the message is redelivered

JMSXDeliveryCount does not appear although the message is redelivered

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Article ID: KB0087863

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Updated On:

Products Versions
TIBCO Enterprise Message Service -
Not Applicable -

Description

Description:
Symptoms
========

A queue is defined with the "maxredelivery" property. When messages are received from that queue, the JMSXDeliveryCount property does not appear in the JMS Message "Properties" field, although this message has been redelivered (the JMSRedelivered flag is set to TRUE).

Impact
======

Loss of Functionality
You will be unable to use the JMSXDeliveryCount property


Workaround
==========

Add a dummy property before sending a message to a queue where "maxredelivery" property is defined.


Cause
=====

This is a defect in the JMS Client. The JMSXDeliveryCount property is not created if the message has no other property defined. All clients API are affected, since 3.1.0 upto and including 4.0.0.


Resolution
=========

This is fixed in the 4.1.0 release.
Symptoms:

Cause:

Issue/Introduction

JMSXDeliveryCount does not appear although the message is redelivered