Products | Versions |
---|---|
TIBCO Enterprise Message Service | - |
Not Applicable | - |
Description:
Symptoms
========
When an application is doing a JNDI lookup, the application appears to hang and finally times out with the following stack trace:
javax.naming.ServiceUnavailableException: Server did not respond to JNDI request
Impact
======
Loss of Functionality
If receiving applications use JNDI lookups, you will be unable to consume messages
Workaround
==========
Do not use JNDI lookup to consume messages
Cause
=====
The JNDI lookup is sending a system message to the EMS Server, requesting the server to return the looked up object. That request is rejected because the message memory limit is reached or because the server is running on reserve memory. In these situations, all new messages are rejected. System messages (such as the ones used in JNDI lookup) should still be accepted.
Resolution
=========
Fixed in EMS 4.1.0
Symptoms:
Cause: