Unable to complete the process when using the CSR toolkit in TIBCO BusinessConnect

Unable to complete the process when using the CSR toolkit in TIBCO BusinessConnect

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Article ID: KB0086787

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
Symptoms
========
Intermittent problems have been reported with the CSR Toolkit (Host Identity Creation Wizard in the Configuration GUI) in BusinessConnect 3.5.0. These problems may result in a failure to complete the identity creation process and result in an inconsistent PKCS #10 request being stored in the repository. Such failures can cause you to restart the entire CSR process, including getting the signed certificate from your certificate authority.

Impact
======
Loss of Functionality

Workaround
==========
Use an alternate tool, such as OpenSSL (or IIS, or any other such tool) to manage your CSR process and to reconcile the signed certificates and CA certificates (to generate the p12 and p7b files necessary for use with BC). We cannot provide usage support for such a third party tool, but you can find an example sequence of OpenSSL commands in the attachment to this notification. If you choose to use OpenSSL, please review and understand the complete procedure before executing these commands.

Cause
=====
TIBCO Engineering is currently investigating these problems, but the cause has not been isolated because of the intermittent nature of the problem

Resolution
==========
Not enough information available at this time.

Symptoms:

Cause:

Issue/Introduction

Unable to complete the process when using the CSR toolkit in TIBCO BusinessConnect

Attachments

Unable to complete the process when using the CSR toolkit in TIBCO BusinessConnect get_app