Problems encountered during installation (or upgrade) of PortalBuilder 4.5.2 prevents the installation from completing.

Problems encountered during installation (or upgrade) of PortalBuilder 4.5.2 prevents the installation from completing.

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Article ID: KB0087271

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Updated On:

Products Versions
TIBCO PortalBuilder -
Not Applicable -

Description

Description:
Symptoms
========
* During installation, the error message: "TIBCO PortalBuilder installer has encountered problems during setup" is displayed when the installer is attempting to verify the LDAP settings.
* Clicking on "Find base DN" button gives the same error.


Impact
======
Loss of Functionality


Workarounds
===========
1) Stop all TIBCO applications running on the machine where you are installing PortalBuilder.
    o Stop any services that are using UDP:7474.
    o Stop any RVD.EXE process that might be running.
    o Restart the PortalBuilder 4.5.2 installation.

2) During PortalBuilder installation, when you get the error:
   o DO NOT exit the installer
   o Go to &ltPortal_Home> directory (where you are currently installing PB 4.5.2)
   o Locate and rename (or copy to a different location) two (2) PB Repository files:
      - TibRepo_PB.dat
      - TibRepo_PB_template.dat
   o Download the linked file "4.5.2-workaround-TibRepo_PB_template.dat.zip" to a temp location.
   o Extract the file TibRepo_PB_template.dat to the temp location.
   o Copy this file to "&ltPortal_Home>\TibRepo_PB_template.dat" , your current 4.5.2
      installation directory [Note: archive contains only 1 file].
   o Return to the PB 4.5.2 install screen and click on the "Find BaseDN" button.
   o The installer will now proceed as expected.

3) Modify your other installed TIBCO products that use UDP:7474 to also use TCP:7500.
   o Restart the other applications for the changes to take affect.
   o Restart the PortalBuilder 4.5.2 installation.
  

Cause
=====
The problem is not directly related to the LDAP, but a previous exception thrown by the initialization routine is being caught when the LDAP test is run.  

If other TIBCO applications are also installed, it is possible for one of them to "own" a system resource required by PB, and PB fails to initialize because of this conflict.  PortalBuilder 4.5.2 uses other 4.x TIBCO components under the covers, such as the Adapter SDK, Rendezvous, and Hawk.  In some cases, other applications will spawn RV daemons on both TCP:7500 and TCP:7474.  PB spawns only one daemon (on TCP:7500), and it sends all UDP traffic through that one daemon.

(PD_Id:1-1PTBB1) has been assigned to track this issue.


Resolution
==========
None.  This can only be fixed in a new release because it will require an installer change.



Symptoms:

Cause:

Issue/Introduction

Problems encountered during installation (or upgrade) of PortalBuilder 4.5.2 prevents the installation from completing.

Attachments

Problems encountered during installation (or upgrade) of PortalBuilder 4.5.2 prevents the installation from completing. get_app