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Article ID: KB0087543
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Updated On:
Description
Resolution:
Symptom:
---------------
I see one of the following advisory messages:
_RV.ERROR.SYSTEM.LICENSE.EXPIRE
_RV.WARN.SYSTEM.LICENSE.EXPIRE
Each Rendezvous daemon process requires a valid license. Some licenses are valid for only a limited time. These messages indicate expiration (ERROR) or impending expiration (WARN) of a license.
Rendezvous daemon presents this warning message to each of its client transports. As an error advisory, this message indicates that the license has already expired. Every affected Rendezvous daemon stops servicing its client programs, and presents this error message to each client transport.
Diagnosis:
---------
There could be 2 reasons for getting these advisories:
1. You do not have a valid RV license ticket.
Please refer to Chapter 2 on Licensing Information in RV Admin Guide or click on the web link to request a valid
(temporary and/or permanent) RV6.x and/or RV7.x license ticket:
http://www.tibco.com/software/enterprise_backbone/rendezvous_download.jsp
2. You have a valid license but there is something wrong with your configuration; please check following:
a. The ticket file should be named "tibrv.tkt" and should be placed in the directory <TIBCO/RV_INSTALL>/bin.
You also need to ensure the PATH environment variable contains the <TIBCO/RV_INSTALL>/bin directory. It is possible that
the PATH is not correctly set; please ensure that the execution path of each user includes the directory that
contains the "tibrv.tkt" file.
b. If you still have the problem, run "rvd"
you should see something like the following:
=======================================================================
TIB/Rendezvous daemon
Copyright 1994-1999 by TIBCO Software Inc.
All rights reserved.
2003-12-04 14:27:57 rvd: Using ticket file c:\tibco\tibrv\bin\tibrv.tkt
=======================================================================
which tells you the ticket file you are using and it’s location, open this tibrv.tkt file, and make sure that it
has the correct ticket license.
c. It is possible that you may have added invisible characters when creating the ticket file, hence corrupting the
key. Please recreate the license ticket file.
d. Please go to the rvd/rvrd HTTP interface, and verify the value of "license ticket:", which should be same as
mentioned in tibrv.tkt after the component name.
Please note that daemons read a license ticket file only during start-up. Recycle the daemons once you have installed a
valid license ticket with correct settings as stated above. This information is valid for RV6.x and RV7.x. For further
details on above advisories, TIBCO/RV licenses, types and how to purchase them please refer to:
- Chapter 2 on Licensing Information in RV Admin Guide.
- Appendix A in RV concepts guide
If you still need help, please send us:
- License ticket file 'tibrv.tkt' as attachment
- System Path variable setting
- Command line output when daemon is started
Issue/Introduction
Why am I getting a message that says my license is about to expire even though I have a permanent license?