TIBCO BusinessWorks Workflow 5.1.0 has a known issue with TRA/BW 5.2.1

TIBCO BusinessWorks Workflow 5.1.0 has a known issue with TRA/BW 5.2.1

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Article ID: KB0090319

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Updated On:

Products Versions
TIBCO BusinessWorks Workflow -
Not Applicable -

Description

Description:
Symptoms
========
This is applicable if you have upgraded to TRA/BW 5.2.1 from the previous version.
After upgrading BW/TRA to 5.2.1, when you try to view WF Process in Designer it complains :

License Check Failure:
No valid license found for ILOG Jviews ....
Reason: File 'keys.jlm' not found


Impact
======
You will not be able to view any WF Process in Designer 5.2.1 and the Designer may hang.


Workaround
==========
Edit &ltTIBCO_HOME>/designer/5.2/bin/designer.tra and &ltTIBCO_HOME>/designer/5.2/bin/validateproject.tra, Remove &ltTIBCO_HOME>/tpcl/5.2/jviews/6.0 from classpath to make sure &ltTIBCO_HOME>/tpcl/5.2/jviews is ahead.

OR

Rename &ltTIBCO_HOME&gttpcl/5.2/jviews/6.0/keys.jlm.old to &ltTIBCO_HOME&gttpcl/5.2/jviews/6.0/keys.jlm


Cause
=====
This issue happens because TRA 5.2.1 installer makes a backup of jviews license file during upgrade & prepends the classpath with jviews/6.0 location.


Resolution
==========
There is NO resolution. This is a one time fix.


Symptoms:

Cause:

Issue/Introduction

TIBCO BusinessWorks Workflow 5.1.0 has a known issue with TRA/BW 5.2.1